Site Tools


cisco:labs:ios_xr:lab_misc_1

IOS-XR BGP, VRF

hostname Router1
vrf portland
 address-family ipv4 unicast
  import route-target
   1:1
  !
  export route-target
   1:1
  !
 !
!
interface MgmtEth0/0/CPU0/0
 shutdown
!
interface GigabitEthernet0/0/0/0
 vrf portland
 ipv4 address 10.0.0.1 255.255.255.252
!
interface GigabitEthernet0/0/0/1
 shutdown
!
interface GigabitEthernet0/0/0/2
 shutdown
!
router bgp 65000
 bgp router-id 1.1.1.1
 address-family ipv4 unicast
 !
 address-family vpnv4 unicast
 !
 vrf portland
  rd 1:1
  bgp router-id 1.1.1.1
  address-family ipv4 unicast
   network 10.0.0.0/30
  !
  neighbor 10.0.0.2
   remote-as 65000
   update-source GigabitEthernet0/0/0/0
   address-family ipv4 unicast
   !
  !
 !
!
end
hostname Router2
vrf portland
 address-family ipv4 unicast
  import route-target
   2:2
  !
  export route-target
   2:2
  !
 !
!
interface MgmtEth0/0/CPU0/0
 shutdown
!
interface GigabitEthernet0/0/0/0
 vrf portland
 ipv4 address 10.0.0.2 255.255.255.252
!
interface GigabitEthernet0/0/0/1
 shutdown
!
interface GigabitEthernet0/0/0/2
 shutdown
!
router bgp 65000
 bgp router-id 2.2.2.2
 address-family ipv4 unicast
 !
 address-family vpnv4 unicast
 !
 vrf portland
  rd 2:2
  bgp router-id 2.2.2.2
  address-family ipv4 unicast
   network 10.0.0.0/30
  !
  neighbor 10.0.0.1
   remote-as 65000
   update-source GigabitEthernet0/0/0/0
   address-family ipv4 unicast
   !
  !
 !
!
end
RP/0/0/CPU0:Router1#ping 10.0.0.2
Thu Nov 21 09:33:43.054 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
UUUUU
Success rate is 0 percent (0/5)
RP/0/0/CPU0:Router1#ping 10.0.0.2 vrf portland
Thu Nov 21 09:34:13.332 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:Router1#show bgp vrf portland neighbor 10.0.0.2 | i state
Thu Nov 21 10:06:06.841 UTC
  BGP state = Established, up for 00:00:53
cisco/labs/ios_xr/lab_misc_1.txt · Last modified: 2025/02/17 23:36 by 127.0.0.1