cisco:dmvpn:eigrp_phase_1-2
Cisco DMVPN Phase 1 and 2 with EIGRP
Notes
NHRP Hub configuration:
Create a tunnel interface on bos1
interface Tunnel0
ip address 172.30.30.1 255.255.255.0
Add private network to routing protocol.
router eigrp 30
network 172.30.30.0
Identify NHRP network-id (like an OSPF area 0).
interface Tunnel0
ip nhrp network-id 30
Allow multicast traffic to traverse DMVPN infrastructure.
interface Tunnel0
ip nhrp map multicast dynamic
Add a tunnel source.
interface Tunnel0
tunnel source GigabitEthernet0/2
Tunnel source is the IP to connect to the NHRP network-id 30.
Aka: the public facing interface.
Define mode to operate tunnel in.
interface Tunnel0
tunnel mode gre multipoint
Tunnel will come up.
Now spokes can be added.
• NHRP Spoke configuration:
Create a tunnel interface on tpa1
interface Tunnel0
ip address 172.30.30.2 255.255.255.0
Add private network to routing protocol.
router eigrp 30
network 172.30.30.0
Define NHRP network-id.
interface Tunnel0
ip nhrp network-id 30
Define tunnel address of the NHRP server (hub).
interface Tunnel0
ip nhrp nhs 172.30.30.1
Map NHRP server address to publicly reachable IP.
interface Tunnel0
ip nhrp map 172.30.30.1 10.0.30.1
Send all multicast traffic to the public IP only.
interface Tunnel0
ip nhrp map multicast 10.0.30.1
Add a tunnel source
interface Tunnel0
tunnel source GigabitEthernet0/2
Tunnel source is the IP to connect to the NHRP network-id 30.
Aka: the public facing interface.
Define mode to operate tunnel in.
interface Tunnel0
tunnel mode gre multipoint
Tunnel will come up.
Repeat NHRP Spoke configuration on each spoke
To verify:
-
Shows neighborship of NHRP Hub at 172.30.30.1.
-
Shows that EIGRP has learned additional routes through the tunnel interface.
-
Can see hops a packet takes to reach a destination.
To allow spoke to spoke communication with EIGRP, split horizon needs to be disabled on the NHRP Hub.
interface Tunnel0
no ip split-horizon eigrp 30
Now the spokes go through the hub to reach another spoke.
This behavior can be modified to allow spoke to spoke communication without going through the hub.
DMPVN Phase 2
Configure hub
interface Tunnel0
no ip next-hop-self eigrp 30
Now packets will flow spoke to spoke without using the hub as a next hop. This creates a dynamic spoke to spoke Phase 2 tunnel and allows a more efficient way for spokes to communicate with each other.
Topology
Device Configurations
pe1
Config hostname pe1
no ip domain lookup
!
interface Loopback0
ip address 192.168.0.1 255.255.255.255
!
interface GigabitEthernet0/0
description mgmt-sw-1;g0/0
ip address 10.255.0.1 255.255.0.0
no shutdown
!
interface GigabitEthernet0/1
description ny1;site-1;10.0.0.2/30;g0/1
ip address 10.0.0.1 255.255.255.252
no shutdown
!
interface GigabitEthernet0/2
description co1;site-2;10.0.0.6/30;g0/1
ip address 10.0.0.5 255.255.255.252
no shutdown
!
interface GigabitEthernet0/3
description ga1;site-3;10.0.0.10/30;g0/1
ip address 10.0.0.9 255.255.255.252
no shutdown
!
interface GigabitEthernet0/4
description tn1;site-4;10.0.0.14/30;g0/1
ip address 10.0.0.13 255.255.255.252
no shutdown
!
interface GigabitEthernet0/5
description tx1;site-5;10.0.0.18/30;g0/1
ip address 10.0.0.17 255.255.255.252
no shutdown
!
router ospf 1
network 10.0.0.1 0.0.0.0 area 0
network 10.0.0.5 0.0.0.0 area 0
network 10.0.0.9 0.0.0.0 area 0
network 10.0.0.13 0.0.0.0 area 0
network 10.0.0.17 0.0.0.0 area 0
!
line con 0
exec-timeout 0 0
logging synchronous
end
!
wr
ny1
Config hostname ny1
no ip domain lookup
!
interface Loopback0
ip address 192.168.1.1 255.255.255.255
!
interface GigabitEthernet0/0
description mgmt-sw-1;g0/1
ip address 10.255.1.1 255.255.0.0
no shutdown
!
interface GigabitEthernet0/1
description pe1;10.0.0.1/30;g0/1
ip address 10.0.0.2 255.255.255.252
no shutdown
!
interface GigabitEthernet0/2
description ny2;10.0.1.2/30;g0/1
ip address 10.0.1.1 255.255.255.252
no shutdown
!
router eigrp 30
network 10.0.1.1 0.0.0.0
network 192.168.1.1 0.0.0.0
!
router ospf 1
network 10.0.0.2 0.0.0.0 area 0
!
line con 0
exec-timeout 0 0
logging synchronous
end
!
wr
ny2
Config hostname ny2
no ip domain lookup
!
interface Loopback0
ip address 192.168.1.2 255.255.255.255
!
interface GigabitEthernet0/0
description mgmt-sw-1;g0/3
ip address 10.255.1.2 255.255.0.0
no shutdown
!
interface GigabitEthernet0/1
description ny1;10.0.1.1/30;g0/2
ip address 10.0.1.2 255.255.255.252
no shutdown
!
router eigrp 30
network 10.0.1.2 0.0.0.0
network 192.168.1.2 0.0.0.0
!
line con 0
exec-timeout 0 0
logging synchronous
end
!
wr
co1
Config hostname co1
no ip domain lookup
!
interface Loopback0
ip address 192.168.2.1 255.255.255.255
!
interface GigabitEthernet0/0
description mgmt-sw-2;g0/0
ip address 10.255.2.1 255.255.0.0
no shutdown
!
interface GigabitEthernet0/1
description pa1;10.0.0.5/30;g0/2
ip address 10.0.0.6 255.255.255.252
no shutdown
!
interface GigabitEthernet0/2
description co2;10.0.2.2/30;g0/1
ip address 10.0.2.1 255.255.255.252
no shutdown
!
router eigrp 30
network 10.0.2.1 0.0.0.0
network 192.168.2.1 0.0.0.0
!
router ospf 1
network 10.0.0.6 0.0.0.0 area 0
!
line con 0
exec-timeout 0 0
logging synchronous
end
!
wr
co2
Config hostname co2
no ip domain lookup
!
interface Loopback0
ip address 192.168.2.2 255.255.255.255
!
interface GigabitEthernet0/0
description mgmt-sw-2;g0/3
ip address 10.255.2.2 255.255.0.0
no shutdown
!
interface GigabitEthernet0/1
description co1;10.0.2.1/30;g0/2
ip address 10.0.2.2 255.255.255.252
no shutdown
!
router eigrp 30
network 10.0.2.2 0.0.0.0
network 192.168.2.2 0.0.0.0
!
line con 0
exec-timeout 0 0
logging synchronous
end
!
wr
ga1
Config hostname ga1
no ip domain lookup
!
interface Loopback0
ip address 192.168.3.1 255.255.255.255
!
interface GigabitEthernet0/0
description mgmt-sw-2;g0/1
ip address 10.255.3.1 255.255.0.0
no shutdown
!
interface GigabitEthernet0/1
description pe1;10.0.0.9/30;g0/3
ip address 10.0.0.10 255.255.255.252
no shutdown
!
interface GigabitEthernet0/2
description ga2;10.0.3.2/30;g0/1
ip address 10.0.3.1 255.255.255.252
no shutdown
!
router eigrp 30
network 10.0.3.1 0.0.0.0
network 192.168.3.1 0.0.0.0
!
router ospf 1
network 10.0.0.10 0.0.0.0 area 0
!
line con 0
exec-timeout 0 0
logging synchronous
end
!
wr
ga2
Config hostname ga2
no ip domain lookup
!
interface Loopback0
ip address 192.168.3.2 255.255.255.255
!
interface GigabitEthernet0/0
description mgmt-sw-2;g1/0
ip address 10.255.3.2 255.255.0.0
no shutdown
!
interface GigabitEthernet0/1
description ga1;10.0.3.1/30;g0/2
ip address 10.0.3.2 255.255.255.252
no shutdown
!
router eigrp 30
network 10.0.3.2 0.0.0.0
network 192.168.3.2 0.0.0.0
!
line con 0
exec-timeout 0 0
logging synchronous
end
!
wr
tn1
Config hostname tn1
no ip domain lookup
!
interface Loopback0
ip address 192.168.4.1 255.255.255.255
!
interface GigabitEthernet0/0
description mgmt-sw-2;g0/2
ip address 10.255.4.1 255.255.0.0
no shutdown
!
interface GigabitEthernet0/1
description pe1;10.0.0.13/30;g0/4
ip address 10.0.0.14 255.255.255.252
no shutdown
!
interface GigabitEthernet0/2
description tn2;10.0.4.2/30;g0/1
ip address 10.0.4.1 255.255.255.252
no shutdown
!
router eigrp 30
network 10.0.4.1 0.0.0.0
network 192.168.4.1 0.0.0.0
!
router ospf 1
network 10.0.0.14 0.0.0.0 area 0
!
line con 0
exec-timeout 0 0
logging synchronous
end
!
wr
tn2
Config hostname tn2
no ip domain lookup
!
interface Loopback0
ip address 192.168.4.2 255.255.255.255
!
interface GigabitEthernet0/0
description mgmt-sw-2;g1/1
ip address 10.255.4.2 255.255.0.0
no shutdown
!
interface GigabitEthernet0/1
description tn1;10.0.4.1/30;g0/2
ip address 10.0.4.2 255.255.255.252
no shutdown
!
router eigrp 30
network 10.0.4.2 0.0.0.0
network 192.168.4.2 0.0.0.0
!
line con 0
exec-timeout 0 0
logging synchronous
end
!
wr
tx1
Config hostname tx1
no ip domain lookup
!
interface Loopback0
ip address 192.168.5.1 255.255.255.255
!
interface GigabitEthernet0/0
description mgmt-sw-1;g0/2
ip address 10.255.5.1 255.255.0.0
no shutdown
!
interface GigabitEthernet0/1
description pe1;10.0.0.17/30;g0/5
ip address 10.0.0.18 255.255.255.252
no shutdown
!
interface GigabitEthernet0/2
description tx2;10.0.5.2/30;g0/1
ip address 10.0.5.1 255.255.255.252
no shutdown
!
router eigrp 30
network 10.0.5.1 0.0.0.0
network 192.168.5.1 0.0.0.0
!
router ospf 1
network 10.0.0.18 0.0.0.0 area 0
!
line con 0
exec-timeout 0 0
logging synchronous
end
!
wr
tx2
Config hostname tx2
no ip domain lookup
!
interface Loopback0
ip address 192.168.5.2 255.255.255.255
!
interface GigabitEthernet0/0
description mgmt-sw-1;g1/0
ip address 10.255.5.2 255.255.0.0
no shutdown
!
interface GigabitEthernet0/1
description tx1;10.0.5.1/30;g0/2
ip address 10.0.5.2 255.255.255.252
no shutdown
!
router eigrp 30
network 10.0.5.2 0.0.0.0
network 192.168.5.2 0.0.0.0
!
line con 0
exec-timeout 0 0
logging synchronous
end
!
wr
cisco/dmvpn/eigrp_phase_1-2.txt · Last modified: 2025/02/17 23:36 by 127.0.0.1