====IOS-XR Lab 5: iBGP with Three Routers part 1====
This lab will configure a third router to form iBGP with three routers. This lab will fail, but will be fixed in Lab 6.
- Configure a third BGP router, connected to R2's G0/0/0/1 interface, with the following parameters:
- Hostname=R3
- Lo0=3.3.3.3/32
- G0/0/0/1=10.0.1.3/24
- BGP ASN=65000
- BGP router-id=3.3.3.3
- HSRP not required at this time
- ++Answer|hostname R3
interface Loopback0
ipv4 address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/0/0/1
description R2; G 0/0/0/1; 10.0.0.1.2/24
ipv4 address 10.0.1.3 255.255.255.0
!
router bgp 65000
bgp router-id 3.3.3.3
address-family ipv4 unicast
network 3.3.3.3/32
network 10.0.1.0/24
!
neighbor 10.0.0.2
remote-as 65000
address-family ipv4 unicast
!
!
neighbor 10.0.1.2
remote-as 65000
address-family ipv4 unicast
++
- On R2:
- G0/0/0/1=10.0.1.2/24
- BGP ASN=65000
- ++Answer|interface GigabitEthernet0/0/0/1
description R3; G 0/0/0/1; 10.0.1.3/24
ipv4 address 10.0.1.2 255.255.255.0
!
router bgp 65000
address-family ipv4 unicast
network 10.0.1.0/24
neighbor 10.0.1.3
remote-as 65000
address-family ipv4 unicast
++
- Verify
- RP/0/0/CPU0:R3#show bgp summ
BGP router identifier 3.3.3.3, local AS number 65000
Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd
10.0.0.2 0 65000 0 0 0 0 0 00:00:00 Active
10.0.1.2 0 65000 6 6 6 0 0 00:02:50 3
- Notice that the 10.0.0.2 neighbor is stuck in Active. This is because iBGP requires a full-mesh topology to prevent routing loops.
[[:cisco:labs:ios_xr:lab6|IOS-XR Lab 6: iBGP with Three Routers part 2]]\\
[[:cisco:labs:ios_xr|IOS-XR Lab Index]]